Firefoxをアップデートしたらfcitxが動かなくなったので

Posted on 2016/07/12
Tags: 環境

Firefoxをアップデートしたらfcitxが動かなくなったので

解決

 Firefoxのバージョンとしては47.0.1だけど、多分43より後のバージョンでは発生する…うちの環境では。

解決方法としては、~/.xinitrcに以下を記述します。 それだけ。

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx
export DefaultIMModule=fcitx

僕の.xinitrcはこんな感じ。 exec startxfce4の後にexportを書いててちょっとハマった。

#!/bin/sh
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx
export DefaultIMModule=fcitx
exec startxfce4

参考


最近いきなりArchが暴れ始めている。
あとはFirefoxだけで音がならない問題を修正しなければ。 …これのせいで、ちょくだいさんのエロゲ放送がほとんど見られなかった…。



この記事はこちらから修正リクエストを送ることができます。
Firefoxをアップデートしたらfcitxが動かなくなったので - github
ゴミ箱ボタンの左にある、鉛筆ボタンを押してね!